• 欢迎访问开心洋葱网站,在线教程,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站,欢迎加入开心洋葱 QQ群
  • 为方便开心洋葱网用户,开心洋葱官网已经开启复制功能!
  • 欢迎访问开心洋葱网站,手机也能访问哦~欢迎加入开心洋葱多维思维学习平台 QQ群
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏开心洋葱吧~~~~~~~~~~~~~!
  • 由于近期流量激增,小站的ECS没能经的起亲们的访问,本站依然没有盈利,如果各位看如果觉着文字不错,还请看官给小站打个赏~~~~~~~~~~~~~!

ACM 1004: Let the Balloon Rise 找到颜色最多的气球

OC/C/C++ 水墨上仙 1090次浏览

题意:给你一堆颜色的气球,让你统计处什么颜色的气球数量最多,输出该颜色。

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. A test case with N = 0 terminates the input and this test case is not to be processed.
Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5 green red blue red red 3 pink orange pink 0

Sample Output

red pink

Author

WU, Jiazhi

Source

ZJCPC2004

代码1:


#include <stdio.h>
#include <string.h>
main(){
    int n, i, j, t, max, num[1000];
    char color[1000][16];
    while(scanf("%d", &n) != EOF){
        if(n){
            num[0]=0;
            scanf("%s", color[0]);
            for(i=1; i <n; i++){
                num[i]=0;
                scanf("%s", color[i]);
                for(j=0; j <i-1; j++)
                    if(strcmp(color[i], color[j])==0) num[i] +=1;
            }
            max=num[0];
            t=0;
            for(i=1; i <n; i++)
               if(max <num[i]) {max =num[i]; t=i;}
            printf("%s\n",color[t]);
        }
    }
}


C++代码


#include<iostream>
#include<map>
#include<string>
using namespace std;

int main()
{
	map<string,int> balloon;
	int n;
	string a;
	while(cin >> n&& n!=0)
	{
		balloon.clear();
		while(n--)
		{
			cin >> a;
			balloon[a]++;
		}
		map<string,int>::iterator it;
		int max=-100;string maxcolor;
		for (it=balloon.begin();it!=balloon.end();it++)
		{
			if((*it).second>max)
			{
				max=(*it).second;
				maxcolor=(*it).first;
			}
		}
		cout<<maxcolor<<endl;
	}
	return 0;
}

C++代码2


#include<iostream>
#include <map>
#include <string>
#include<algorithm>
using namespace std;
const int MAX=10010;
int main()
{
    //freopen("1.txt","r",stdin);
    int n;
    char col[20];
    while(cin>>n)
    {
        if(n==0) break;
        map<string,int> balloons;
        for (int i=0;i<n;i++)
        {
            cin>>col;
            balloons[col]++;
        }
        map<string,int>::iterator p,m;
        p=m=balloons.begin();
        for (p;p!=balloons.end();p++)
        {
            if(p->second > m->second) m=p;
        }
        cout<<m->first<<endl;
    }
}


开心洋葱 , 版权所有丨如未注明 , 均为原创丨未经授权请勿修改 , 转载请注明ACM 1004: Let the Balloon Rise 找到颜色最多的气球
喜欢 (0)
加载中……