• 欢迎访问开心洋葱网站,在线教程,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站,欢迎加入开心洋葱 QQ群
  • 为方便开心洋葱网用户,开心洋葱官网已经开启复制功能!
  • 欢迎访问开心洋葱网站,手机也能访问哦~欢迎加入开心洋葱多维思维学习平台 QQ群
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏开心洋葱吧~~~~~~~~~~~~~!
  • 由于近期流量激增,小站的ECS没能经的起亲们的访问,本站依然没有盈利,如果各位看如果觉着文字不错,还请看官给小站打个赏~~~~~~~~~~~~~!

ACM 1002:A + B Problem II Java代码范例

JAVA相关 水墨上仙 2876次浏览

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

问题描述:

一个很简单的问题,给你两个整数A和B,你的工作就是计算出A+B

输入:

第一行输入一个范围在1~20的整数T,代表测试的组数。然后再输入T行,每行两个整数A和B。注意:整数非常大,你不能用int型的变量来表示,你可以假设每个数的位数不超过1000位

输出:每组测试都需要输出两行,第一行是Case:#,#代表测试的组号,第二行输出一个等式A + B = SUM,SUM是A+B的结果,注意:在这个等式中有一些空格。在每两组测试之间输出一行空行

代码转自:http://blog.csdn.net/lkxiaolou/

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String[] args){
		Scanner sc=new Scanner(System.in);
		int n=sc.nextInt();
		int temp,flag=n;
		BigInteger a,b,c;
		while(n!=0)
			{
			a=sc.nextBigInteger();
			b=sc.nextBigInteger();
			c=add(a,b);
			temp=flag-n+1;
			System.out.println("Case "+temp+":");
			System.out.println(a+" + "+b+" = "+c);
			n=n-1;
			if(n!=0){System.out.println("");}
			}
	}
	public static BigInteger add(BigInteger a,BigInteger b)
	{
		BigInteger c=a.add(b);
		return c;
	}
}


开心洋葱 , 版权所有丨如未注明 , 均为原创丨未经授权请勿修改 , 转载请注明ACM 1002:A + B Problem II Java代码范例
喜欢 (0)
加载中……