• 欢迎访问开心洋葱网站,在线教程,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站,欢迎加入开心洋葱 QQ群
  • 为方便开心洋葱网用户,开心洋葱官网已经开启复制功能!
  • 欢迎访问开心洋葱网站,手机也能访问哦~欢迎加入开心洋葱多维思维学习平台 QQ群
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏开心洋葱吧~~~~~~~~~~~~~!
  • 由于近期流量激增,小站的ECS没能经的起亲们的访问,本站依然没有盈利,如果各位看如果觉着文字不错,还请看官给小站打个赏~~~~~~~~~~~~~!

杭电ACM 1102 Constructing Roads : 求连接所有村庄的最短路径

OC/C/C++ 水墨上仙 1849次浏览

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11072 Accepted Submission(s): 4129

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3

0 990 692

990 0 179

692 179 0

1

1 2

Sample Output

179

C语言代码,转自:http://blog.csdn.net/u011518888/


#include<algorithm>

using namespace std;


struct node
{
int x,y;
int z;
}a[50000];


int pre[50000];
int find(int k)
{
if(k==pre[k])
return k;
return pre[k]=find(pre[k]);
}


int cmp(node a,node b)
{
return a.z<b.z;
}


int main()
{
int n,m,r,t,f1,f2,ans,i,j,q;
while(scanf("%d",&n)!=EOF)
{
q=0;
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
scanf("%d",&a[q].z);
a[q].x=i;
a[q].y=j;
q++;
}
sort(a,a+q,cmp);
for(i=1;i<=q;i++)
pre[i]=i;
scanf("%d",&m);
for(i=1;i<=m;i++)
{
scanf("%d%d",&r,&t);
f1=find(r);
f2=find(t);
if(f1!=f2)
pre[f1]=f2;
}
ans=0;
for(i=0;i<q;i++)
{
f1=find(a[i].x);
f2=find(a[i].y);
if(f1!=f2)
{
pre[f1]=f2;
ans+=a[i].z;
}
}
printf("%d\n",ans);
}
return 0;
}


开心洋葱 , 版权所有丨如未注明 , 均为原创丨未经授权请勿修改 , 转载请注明杭电ACM 1102 Constructing Roads : 求连接所有村庄的最短路径
喜欢 (0)
加载中……